This project is read-only.

Problems with large projects and nmaven

Mar 23, 2009 at 10:11 PM

Hello,

I have been using nmaven 0.17 with some success but have hit a problem as my projects grow larger.  I'm also having some trouble stapling down a reliable test case so thought I would ask this while working on that in parallel.  Essentially I am seeing that while when I invoke a bunch of projects using nmaven, that they work fine.  But if I use a parent pom to put them all together, I eventually start getting two classes of error.  I believe they are the same however.

The first one is when I expect a .dll to be published to the local repository, I am instead getting a zero byte .dotnet file.

The second class is when trying to publish a .dll to the local repository I get an error.  Essentially it looks like it is copy foo.dll to foo.dotnet:library.  Essentially the error looks like this:


[INFO] Installing E:\builddir\project1\project1a\target\project1a.dll to E:\builddir\maven_repo\com\pervasive\test\project1\project1a\1.0.0\project1a-1.0.0.dotnet:library
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error installing artifact: The filename, directory name, or volume label syntax is incorrect

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------

If I run that component standalone, it works just fine.

Anyone seen anything like that?

-Jim